I have downloaded the GN Entourage mobile client for iOS, added the client-id, client tag and the license info and tried to run it. I get the following error:



getUserACR: ERROR: User Create New: client id '4199680' not supported by current license

2013-08-08 11:59:12.699 GN_Entourage_Demo[3003:907] Error: Invalid User


Not sure why 


user  = [[GnUser alloc] initWithClientId:CLIENT_ID



                                registrationType:GnUserRegistrationType_NewUser error:&error];


is returning null.


Any help is appreciated.




Hello, This is likely related to the way the license text is formatted in your source code.  Please try following these steps:1.  Uninstall any Entourage app from your device and/or simulator2.  Make sure that the license text is entered in your source code as a single line with all newlines escaped with "\n".  For example: 

  1. License text with line breaks (this won't work):
    -- BEGIN LICENSE v1.0 29BB27FA --
    licensee: Gracenote, Inc.
    name: AE_ACR_Testing
    start_date: 2012-03-22
    client_id: xxxxxxx
    videoid: enabled
    videoid_explore: enabled
    -- SIGNATURE 29BB27FA --
    -- END LICENSE 29BB27FA --
    License text where line breaks have been replaced with escaped newline characters (this will work):
    -- BEGIN LICENSE v1.0 29BB27FA --\nlicensee: Gracenote, Inc.\nname: AE_ACR_Testing\nstart_date: 2012-03-22\n\nclient_id:xxxxxxx\nvideoid: enabled\nvideoid_explore: enabled\n\n-- SIGNATURE 29BB27FA --
    lAADAgAeRYeFbHD5itkXPpw4xlyhy0Na/TJ/niuX+mmQb+tXAB6V7219Nai51TjK7bzsH2RR/PhmWm7qpfJBIldl7RY=\n-- END LICENSE 29BB27FA --

Hi - I made the changes suggested by you and I now see the following error:  2013-08-09 11:14:38.739 GN_Entourage_Demo[3649:907] getUserACR: ERROR: UNKNOWN DESCRIPTION2013-08-09 11:14:38.741 GN_Entourage_Demo[3649:907] Error: Invalid User Thanks, 

Can you post the client id, client tag and license text as it appears in your source code?Thanks. 

Hi Guna, Note: I removed the client id and license info from the forums so as not to make them publicly viewable.  It appears that there is something wrong with your license text.  Perhaps something was missed when you copied it from the developer page into your source code.  Can you try creating a new app in the "My Apps" page, selecting "Entourage" as the platform.  This should generate a new client id and license information.  Make sure you copy the entire contents of the license text.  Also, as I mentioned earlier you will need to escape the newlines in the license text before pasting it into your source code.  Once you've created a new app entry in the "My Apps" section can you try uninstalling the previous app from the device and/or simulator and building the sample with the new client id and license information? Thanks

Hello - I started afresh by creating a new app and got  a new set of client-id and license info. I also got  a fresh copy of sample code from git repo and did a fresh build. I still get the same error. Can we get on the phone and resolve this issue? Thanks much!

I am pretty sure there is something as simple as string mismatch in the license string. Hope we can resolve this today, so that I can move forward with my evaluation. Thanks.

Forum Discussions