When I try to build for iPhone 5, I get an Apple Mach-O Linker Error that includes " file is universal (3 slices) but does not contain a(n) armv7s slice:"

Is there any special build settings that I need to setup?


 The linker problem you are reporting is because the version of the Mobile Client SDK you are using (Version 2.5.7) was not compiled / linked to support the ARMv7s architecture (used for iPhone 5 and iPad 4). Gracenote will be providing a newer version (Version 3.1.0) of the Mobile Client in the next couple of weeks that supports the ARMv7s architecture and you should use that to develop your application on the iPhone 5. For now, I suggest you use the existing Mobile Client SDK and use ARMv7 architecture to develop and test your application either on the simulator or on an ARMv7 device (iPhone 4, iPhone 4S, iPad 2, iPad 3, iPad Mini etc.) until Mobile Client version 3.1.0 is available. 

Hi,when is the release of the v 3.1.0 planned? The post was in february... this is not just a couple of weeks.Can you please provide the newer version? Or at least an armv7s compiled version? Thank you,Marco

Forum Discussions